summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2015-01-04 00:23:53 -0600
committerJohn Wiegley <johnw@newartisans.com>2015-01-04 00:23:53 -0600
commit599af4642c24ab8db542aec19a25c367f3ed01f8 (patch)
treee585b0322667a4cdc5f9eedf602ad45dead434b7 /CMakeLists.txt
parentd6f194058fbf8c88b926c2cb7ed43aa4ff255bc0 (diff)
parentea397d205c84d01b8089e8fac0dd30e9100d1571 (diff)
downloadfork-ledger-599af4642c24ab8db542aec19a25c367f3ed01f8.tar.gz
fork-ledger-599af4642c24ab8db542aec19a25c367f3ed01f8.tar.bz2
fork-ledger-599af4642c24ab8db542aec19a25c367f3ed01f8.zip
Merge pull request #361 from lowdef/cygwin-build
automating ledger build on Cygwin
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee88fe4a..30c6519e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,11 @@ set(Ledger_VERSION_DATE 20141005)
enable_testing()
-add_definitions(-std=c++11)
+if (CYGWIN)
+ add_definitions(-std=c++11 -U__STRICT_ANSI__)
+else()
+ add_definitions(-std=c++11)
+endif()
if (CYGWIN)
add_definitions(-U__STRICT_ANSI__)