summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2016-11-13 15:18:46 -0800
committerJohn Wiegley <johnw@newartisans.com>2016-11-13 15:18:46 -0800
commit71b89f1fc60bf708759291a7c26949d4adcf5cea (patch)
tree6e0c81d5337fd46d96c3d2530fb33f3d1cc56922 /CMakeLists.txt
parent121687a0265d4e874300de0d00d03834a9e20bcd (diff)
downloadfork-ledger-71b89f1fc60bf708759291a7c26949d4adcf5cea.tar.gz
fork-ledger-71b89f1fc60bf708759291a7c26949d4adcf5cea.tar.bz2
fork-ledger-71b89f1fc60bf708759291a7c26949d4adcf5cea.zip
Escape ++ in cmake matches
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e11aa44d..f8dbd892 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -299,7 +299,7 @@ configure_file(
${PROJECT_BINARY_DIR}/system.hh)
if((CMAKE_CXX_COMPILER MATCHES "clang") OR
- (CMAKE_CXX_COMPILER MATCHES "clang++"))
+ (CMAKE_CXX_COMPILER MATCHES "clang\\+\\+"))
set(CMAKE_INCLUDE_SYSTEM_FLAG_CXX "-isystem ")
endif()