summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2014-12-30 12:49:00 -0600
committerJohn Wiegley <johnw@newartisans.com>2014-12-30 12:49:00 -0600
commit8e79b3c7c74081b63f9d8b1e0ec97478f61d4ba8 (patch)
tree07fb238dcfb96130a38ab191fa75507b7c85ad33 /CMakeLists.txt
parentd4346ae6d84952c74584b2cdd60d0135644093a8 (diff)
parentac5fd3afd3826a9b0fadcb270900cf42c5ee6e39 (diff)
downloadfork-ledger-8e79b3c7c74081b63f9d8b1e0ec97478f61d4ba8.tar.gz
fork-ledger-8e79b3c7c74081b63f9d8b1e0ec97478f61d4ba8.tar.bz2
fork-ledger-8e79b3c7c74081b63f9d8b1e0ec97478f61d4ba8.zip
Merge pull request #345 from afh/pull/cmake_warning
Set CMake policy CMP0042
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09d14051..5cc49fa8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,8 @@
cmake_minimum_required(VERSION 2.8.5)
+if(POLICY CMP0042)
+ # CMP0042 is only known to CMake 3.0 and above
+ cmake_policy(SET CMP0042 OLD)
+endif(POLICY CMP0042)
PROJECT(ledger)