summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2013-01-14 12:44:08 -0800
committerJohn Wiegley <johnw@newartisans.com>2013-01-14 12:44:08 -0800
commitbf8b7e47e6bafb33c841a4bfe41c05457dfe029a (patch)
tree2a00a05bc7eabcc005f2b5fd00dbacda2d74c69f /CMakeLists.txt
parent0790920424befd67db7b986724b70f72b2d9592b (diff)
parentc88862fd66489fa8c06d06d3876b2c0f59dff3a5 (diff)
downloadfork-ledger-bf8b7e47e6bafb33c841a4bfe41c05457dfe029a.tar.gz
fork-ledger-bf8b7e47e6bafb33c841a4bfe41c05457dfe029a.tar.bz2
fork-ledger-bf8b7e47e6bafb33c841a4bfe41c05457dfe029a.zip
Merge pull request #119 from kljohann/cmake.docs
convert doc/Makefile to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4109a17..132d7c47 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.5)
-project(Ledger)
+PROJECT(ledger)
set(Ledger_VERSION_MAJOR 3)
set(Ledger_VERSION_MINOR 0)
@@ -18,7 +18,8 @@ option(DISABLE_ASSERTS "Build without any internal consistency checks" OFF)
option(BUILD_DEBUG "Build support for runtime debugging" OFF)
option(BUILD_LIBRARY "Build and install Ledger as a library" ON)
-option(BUILD_DOCS "Build and install documentation" OFF)
+option(BUILD_DOCS "Build and install documentation" ON)
+option(BUILD_WEB_DOCS "Build version of documentation suitable for viewing online" OFF)
option(BUILD_EMACSLISP "Build and install ledger-mode for Emacs" OFF)
if(BUILD_DEBUG)