summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-08 03:12:29 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:40 -0400
commit0c10d1c3fdf4fa17e9880d318ee37c4b45d0daf2 (patch)
tree74ecbb37abcc9b283186c0f41bb84ee8ab7d3cda /Makefile.am
parentfa81dc479801ba1343695d66cdb37d8b80bfae9d (diff)
downloadfork-ledger-0c10d1c3fdf4fa17e9880d318ee37c4b45d0daf2.tar.gz
fork-ledger-0c10d1c3fdf4fa17e9880d318ee37c4b45d0daf2.tar.bz2
fork-ledger-0c10d1c3fdf4fa17e9880d318ee37c4b45d0daf2.zip
Use valgrind if it's available.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 81e6da18..8eb15b8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -238,8 +238,10 @@ fullcheck: UnitTests
MallocGuardEdges=1 \
MallocScribble=1 \
MallocPreScribble=1 \
+ MallocCheckHeapStart=100 \
+ MallocCheckHeapEach=100 \
DYLD_INSERT_LIBRARIES=/usr/lib/libgmalloc.dylib \
- $(top_builddir)/UnitTests --verify
+ $(srcdir)/valgrind.sh $(top_builddir)/UnitTests --verify
######################################################################