summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2009-02-21 19:52:31 -0400
committerJohn Wiegley <johnw@newartisans.com>2009-02-21 20:20:57 -0400
commit66c5cd44277863708fdc81a6418bc84215b0c269 (patch)
treef78fdbae25244af9260466e2ab01cc3e131491f2 /Makefile.am
parenta577e8c48ebe3b540a6833e1d37025d53c8a42a7 (diff)
downloadfork-ledger-66c5cd44277863708fdc81a6418bc84215b0c269.tar.gz
fork-ledger-66c5cd44277863708fdc81a6418bc84215b0c269.tar.bz2
fork-ledger-66c5cd44277863708fdc81a6418bc84215b0c269.zip
Use a "format accumulator" for error strings
This makes it possible to internationalize strings while still using I/O streams. For example: std::cout << ACCUM(_("Hello to %1 and %2!") << "me" << "you") << std::endl;
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f40166bc..6d6e4532 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,7 @@ libledger_util_la_SOURCES = \
src/times.cc \
src/error.cc \
src/utils.cc \
+ src/accum.cc \
lib/sha1.cpp
libledger_util_la_CPPFLAGS = $(lib_cppflags)
@@ -86,6 +87,7 @@ pkginclude_HEADERS = \
src/stream.h \
src/pstream.h \
src/unistring.h \
+ src/accum.h \
\
src/amount.h \
src/commodity.h \