summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-08 08:38:01 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:41 -0400
commit92b85dde25b683e1cf58dbab9a7500d81cb2c418 (patch)
treee26183108abd34b8b11a3a1aa5ca3e406b75aeed /Makefile.am
parentd594f6627c947f965b6e43a1291f37e495c22261 (diff)
downloadfork-ledger-92b85dde25b683e1cf58dbab9a7500d81cb2c418.tar.gz
fork-ledger-92b85dde25b683e1cf58dbab9a7500d81cb2c418.tar.bz2
fork-ledger-92b85dde25b683e1cf58dbab9a7500d81cb2c418.zip
Added --boost-suffix.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 86cdcd76..2ec279b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -178,16 +178,11 @@ ledger_so_SOURCES = \
src/py_amount.cc
ledger_so_DEPENDENCIES = libledger.la gdtoa/libgdtoa.la libpyledger.la
-PYLIBS = pyledger ledger gdtoa gmp
-if USE_BOOST_SD
-PYLIBS += boost_date_time-sd boost_filesystem-sd boost_regex-sd boost_python-sd
-else
-if USE_BOOST_D
-PYLIBS += boost_date_time-d boost_filesystem-d boost_regex-d boost_python-d
-else
-PYLIBS += boost_date_time boost_filesystem boost_regex boost_python
-endif
-endif
+PYLIBS = pyledger ledger gdtoa gmp
+PYLIBS += boost_date_time$(BOOST_SUFFIX) \
+ boost_filesystem$(BOOST_SUFFIX) \
+ boost_regex$(BOOST_SUFFIX) \
+ boost_python$(BOOST_SUFFIX)
if HAVE_EXPAT
PYLIBS += expat