summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-04-23 21:22:24 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:31 -0400
commit9039e728b2015b54dc87da52f450c27683303392 (patch)
treeac914e05db5dc03f6971cd8c165ee3791a614d18 /configure.in
parent340dacf118f2f457ffc962cb46e8b3ef59017376 (diff)
downloadfork-ledger-9039e728b2015b54dc87da52f450c27683303392.tar.gz
fork-ledger-9039e728b2015b54dc87da52f450c27683303392.tar.bz2
fork-ledger-9039e728b2015b54dc87da52f450c27683303392.zip
All system headers (except Boost) now included through system.hh;
also, added support for pre-compiled headers since I'm now using a centralized resource for system headers.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 17 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 8bb6247f..1ff68b20 100644
--- a/configure.in
+++ b/configure.in
@@ -17,14 +17,13 @@ AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
AM_PROG_LIBTOOL
-AC_PROG_YACC
-
-AC_PROG_LEX
-if test "$LEX" != flex; then
- LEX="$SHELL $missing_dir/missing flex"
- AC_SUBST(LEX_OUTPUT_ROOT, lex.yy)
- AC_SUBST(LEXLIB, '')
-fi
+#AC_PROG_YACC
+#AC_PROG_LEX
+#if test "$LEX" != flex; then
+# LEX="$SHELL $missing_dir/missing flex"
+# AC_SUBST(LEX_OUTPUT_ROOT, lex.yy)
+# AC_SUBST(LEXLIB, '')
+#fi
# Checks for emacs lisp path
AM_PATH_LISPDIR
@@ -317,6 +316,16 @@ AC_ARG_ENABLE(debug,
AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
+AC_ARG_ENABLE(pch,
+ [ --enable-pch Use GCC 4.x pre-compiled headers],
+ [case "${enableval}" in
+ yes) pch=true ;;
+ no) pch=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-pch) ;;
+ esac],[pch=true])
+
+AM_CONDITIONAL(USE_PCH, test x$pch = xtrue)
+
# Checks for header files.
AC_STDC_HEADERS
AC_HAVE_HEADERS(sys/stat.h langinfo.h)