summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 17 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 8bb6247f..1ff68b20 100644
--- a/configure.in
+++ b/configure.in
@@ -17,14 +17,13 @@ AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
AM_PROG_LIBTOOL
-AC_PROG_YACC
-
-AC_PROG_LEX
-if test "$LEX" != flex; then
- LEX="$SHELL $missing_dir/missing flex"
- AC_SUBST(LEX_OUTPUT_ROOT, lex.yy)
- AC_SUBST(LEXLIB, '')
-fi
+#AC_PROG_YACC
+#AC_PROG_LEX
+#if test "$LEX" != flex; then
+# LEX="$SHELL $missing_dir/missing flex"
+# AC_SUBST(LEX_OUTPUT_ROOT, lex.yy)
+# AC_SUBST(LEXLIB, '')
+#fi
# Checks for emacs lisp path
AM_PATH_LISPDIR
@@ -317,6 +316,16 @@ AC_ARG_ENABLE(debug,
AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
+AC_ARG_ENABLE(pch,
+ [ --enable-pch Use GCC 4.x pre-compiled headers],
+ [case "${enableval}" in
+ yes) pch=true ;;
+ no) pch=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-pch) ;;
+ esac],[pch=true])
+
+AM_CONDITIONAL(USE_PCH, test x$pch = xtrue)
+
# Checks for header files.
AC_STDC_HEADERS
AC_HAVE_HEADERS(sys/stat.h langinfo.h)