summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-08 08:38:01 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:41 -0400
commit92b85dde25b683e1cf58dbab9a7500d81cb2c418 (patch)
treee26183108abd34b8b11a3a1aa5ca3e406b75aeed /configure.in
parentd594f6627c947f965b6e43a1291f37e495c22261 (diff)
downloadfork-ledger-92b85dde25b683e1cf58dbab9a7500d81cb2c418.tar.gz
fork-ledger-92b85dde25b683e1cf58dbab9a7500d81cb2c418.tar.bz2
fork-ledger-92b85dde25b683e1cf58dbab9a7500d81cb2c418.zip
Added --boost-suffix.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 7 insertions, 28 deletions
diff --git a/configure.in b/configure.in
index 2a024690..38521907 100644
--- a/configure.in
+++ b/configure.in
@@ -39,34 +39,6 @@ AC_ARG_ENABLE(debug,
AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
-AC_ARG_ENABLE(boost-sd,
- [ --enable-boost-sd Use static/debug Boost libraries],
- [case "${enableval}" in
- yes) boost_sd=true ;;
- no) boost_sd=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-boost-sd) ;;
- esac],[boost_sd=false])
-
-AM_CONDITIONAL(USE_BOOST_SD, test x$boost_sd = xtrue)
-
-AC_ARG_ENABLE(boost-d,
- [ --enable-boost-d Use dynamic/debug Boost libraries],
- [case "${enableval}" in
- yes) boost_d=true ;;
- no) boost_d=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-boost-d) ;;
- esac],[boost_d=false])
-
-AM_CONDITIONAL(USE_BOOST_D, test x$boost_d = xtrue)
-
-if test x$boost_sd = xtrue; then
- BOOST_SUFFIX="-sd"
-elif test x$boost_d = xtrue; then
- BOOST_SUFFIX="-d"
-else
- BOOST_SUFFIX=""
-fi
-
AC_ARG_ENABLE(pch,
[ --enable-pch Use GCC 4.x pre-compiled headers],
[case "${enableval}" in
@@ -77,6 +49,13 @@ AC_ARG_ENABLE(pch,
AM_CONDITIONAL(USE_PCH, test x$pch = xtrue)
+AC_ARG_WITH(boost-suffix,
+ [ --with-boost-suffix=X Append X to the Boost library names],
+ [BOOST_SUFFIX="-${withval}"],
+ [BOOST_SUFFIX=""])
+
+AC_SUBST([BOOST_SUFFIX], $BOOST_SUFFIX)
+
# check if UNIX pipes are available
AC_CACHE_CHECK(
[if pipes can be used],