summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2014-05-04 01:16:19 +0200
committerAlexis Hildebrandt <afh@surryhill.net>2014-05-05 06:45:42 +0200
commit851dea238ac230d44c5df00dd738cee9aa5780d3 (patch)
tree034e8994384ac86d268c3cae7d5af4b4ba534bdc /doc/CMakeLists.txt
parent87bcfee8fd3054fa22deb1cc2e8eb32943c509e3 (diff)
downloadfork-ledger-851dea238ac230d44c5df00dd738cee9aa5780d3.tar.gz
fork-ledger-851dea238ac230d44c5df00dd738cee9aa5780d3.tar.bz2
fork-ledger-851dea238ac230d44c5df00dd738cee9aa5780d3.zip
Check for required TeX when building pdf documentation
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index cd68f828..e359c5e4 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -36,6 +36,7 @@ set(info_files ledger3.texi ledger-mode.texi)
find_program(MAKEINFO makeinfo)
find_program(TEXI2PDF texi2pdf)
+find_program(TEX tex)
find_program(MAN2HTML man2html)
find_program(GROFF groff)
@@ -56,9 +57,8 @@ foreach(file ${info_files})
if(BUILD_WEB_DOCS)
if(NOT MAKEINFO)
- message(FATAL_ERROR "Could not find makeinfo. HTML version of documentation cannot be built.")
+ message(WARNING "Could not find makeinfo. HTML version of documentation cannot be built.")
endif()
-
add_custom_command(OUTPUT ${file_base}.html
COMMAND makeinfo --force --html --no-split -o ${file_base}.html ${CMAKE_CURRENT_SOURCE_DIR}/${file}
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${file}
@@ -66,8 +66,8 @@ foreach(file ${info_files})
list(APPEND ledger_doc_files ${file_base}.html)
endif(BUILD_WEB_DOCS)
- if(NOT TEXI2PDF)
- message(WARNING "Could not find texi2pdf. PDF version of documentation will not be built.")
+ if(NOT TEXI2PDF OR NOT TEX)
+ message(WARNING "Could not find texi2pdf or tex. PDF version of documentation will not be built.")
else()
if(BUILD_A4_PDF)
set(papersize --texinfo=@afourpaper)