summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2006-02-28 14:40:49 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 02:41:28 -0400
commit0c55a5ee1b5b35f399de7286cd8c6565a61e9634 (patch)
tree47c247481db46d478133eddade540f90c34402b3 /setup.py
parent9db08c4c7de7b2058363bec4a3000f48fc78d580 (diff)
downloadfork-ledger-0c55a5ee1b5b35f399de7286cd8c6565a61e9634.tar.gz
fork-ledger-0c55a5ee1b5b35f399de7286cd8c6565a61e9634.tar.bz2
fork-ledger-0c55a5ee1b5b35f399de7286cd8c6565a61e9634.zip
(read_binary_journal): Fixed a tiny memory leak when reading from a
binary cache.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..5f79efa3
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python
+
+from distutils.core import setup, Extension
+
+import os
+
+libs = ["amounts", "boost_python", "gmp"]
+
+setup(name = "Amounts",
+ version = "2.6",
+ description = "Amounts and Commodities Library",
+ author = "John Wiegley",
+ author_email = "johnw@newartisans.com",
+ url = "http://www.newartisans.com/johnw/",
+ ext_modules = [
+ Extension("amounts", ["amounts.cc"],
+ define_macros = [('PYTHON_MODULE', 1)],
+ libraries = libs)])