summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..5f79efa3
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python
+
+from distutils.core import setup, Extension
+
+import os
+
+libs = ["amounts", "boost_python", "gmp"]
+
+setup(name = "Amounts",
+ version = "2.6",
+ description = "Amounts and Commodities Library",
+ author = "John Wiegley",
+ author_email = "johnw@newartisans.com",
+ url = "http://www.newartisans.com/johnw/",
+ ext_modules = [
+ Extension("amounts", ["amounts.cc"],
+ define_macros = [('PYTHON_MODULE', 1)],
+ libraries = libs)])