summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2008-04-13 03:35:00 -0400
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:35:00 -0400
commit42f43b7686038e4cbca16d8d2118b139544e6de3 (patch)
tree52c5473401c57282242d66b8dd75f4c07bf41d07 /setup.py
parentc7b4370ff9c8ab5c96f15b1e712e6db6bdab6324 (diff)
downloadfork-ledger-42f43b7686038e4cbca16d8d2118b139544e6de3.tar.gz
fork-ledger-42f43b7686038e4cbca16d8d2118b139544e6de3.tar.bz2
fork-ledger-42f43b7686038e4cbca16d8d2118b139544e6de3.zip
Check in all changes made so far toward 3.0.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py24
1 files changed, 18 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 5f79efa3..2034f2b7 100755
--- a/setup.py
+++ b/setup.py
@@ -4,15 +4,27 @@ from distutils.core import setup, Extension
import os
-libs = ["amounts", "boost_python", "gmp"]
+libs = ["ledger", "boost_python", "gmp", "pcre"]
-setup(name = "Amounts",
- version = "2.6",
- description = "Amounts and Commodities Library",
+if os.environ.has_key ("HAVE_EXPAT") and\
+ os.environ["HAVE_EXPAT"] == "true":
+ libs.extend (["expat"])
+
+if os.environ.has_key ("HAVE_XMLPARSE") and\
+ os.environ["HAVE_XMLPARSE"] == "true":
+ libs.extend (["xmlparse", "xmltok"])
+
+if os.environ.has_key ("HAVE_LIBOFX") and\
+ os.environ["HAVE_LIBOFX"] == "true":
+ libs.extend (["ofx"])
+
+setup(name = "Ledger",
+ version = "3.0",
+ description = "Ledger Accounting Library",
author = "John Wiegley",
author_email = "johnw@newartisans.com",
- url = "http://www.newartisans.com/johnw/",
+ url = "http://johnwiegley.com/",
ext_modules = [
- Extension("amounts", ["amounts.cc"],
+ Extension("ledger", ["pyledger.cc"],
define_macros = [('PYTHON_MODULE', 1)],
libraries = libs)])