diff options
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 24 |
1 files changed, 18 insertions, 6 deletions
@@ -4,15 +4,27 @@ from distutils.core import setup, Extension import os -libs = ["amounts", "boost_python", "gmp"] +libs = ["ledger", "boost_python", "gmp", "pcre"] -setup(name = "Amounts", - version = "2.6", - description = "Amounts and Commodities Library", +if os.environ.has_key ("HAVE_EXPAT") and\ + os.environ["HAVE_EXPAT"] == "true": + libs.extend (["expat"]) + +if os.environ.has_key ("HAVE_XMLPARSE") and\ + os.environ["HAVE_XMLPARSE"] == "true": + libs.extend (["xmlparse", "xmltok"]) + +if os.environ.has_key ("HAVE_LIBOFX") and\ + os.environ["HAVE_LIBOFX"] == "true": + libs.extend (["ofx"]) + +setup(name = "Ledger", + version = "3.0", + description = "Ledger Accounting Library", author = "John Wiegley", author_email = "johnw@newartisans.com", - url = "http://www.newartisans.com/johnw/", + url = "http://johnwiegley.com/", ext_modules = [ - Extension("amounts", ["amounts.cc"], + Extension("ledger", ["pyledger.cc"], define_macros = [('PYTHON_MODULE', 1)], libraries = libs)]) |