summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2016-11-13 16:05:05 -0800
committerJohn Wiegley <johnw@newartisans.com>2016-11-13 16:05:05 -0800
commit9c2bc01d525989363831799b8ace78dcd7c024aa (patch)
tree2c30b02c46143df96577b649a32d12571315be80 /src/CMakeLists.txt
parente21697d7b123f00be3005ec2a32e0aa12ba94028 (diff)
downloadfork-ledger-9c2bc01d525989363831799b8ace78dcd7c024aa.tar.gz
fork-ledger-9c2bc01d525989363831799b8ace78dcd7c024aa.tar.bz2
fork-ledger-9c2bc01d525989363831799b8ace78dcd7c024aa.zip
Further simplifications src/CMakeLists.txt
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6d35aff3..71d9478a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -138,9 +138,7 @@ set(LEDGER_INCLUDES
${PROJECT_BINARY_DIR}/system.hh)
if (CMAKE_BUILD_TYPE STREQUAL "Debug")
- if ((CMAKE_CXX_COMPILER MATCHES "clang") OR
- (CMAKE_CXX_COMPILER MATCHES "clang\\+\\+") OR
- (CMAKE_CXX_COMPILER MATCHES "cxx"))
+ if (CMAKE_CXX_COMPILER MATCHES "clang\\+\\+")
add_definitions(
# -Weverything
# -Wno-disabled-macro-expansion
@@ -155,6 +153,7 @@ if (CMAKE_BUILD_TYPE STREQUAL "Debug")
# -Wno-c++98-compat
# -fno-limit-debug-info
-Wno-\#pragma-messages
+ -Wno-unused-local-typedef
--system-header-prefix=include/boost/
--system-header-prefix=boost/)
@@ -194,8 +193,7 @@ if (CMAKE_BUILD_TYPE STREQUAL "Debug")
DEPENDS ${_header_filename})
endmacro(ADD_PCH_RULE _header_filename _src_list _other_srcs)
- elseif ((CMAKE_CXX_COMPILER MATCHES "g\\+\\+") OR
- (CMAKE_CXX_COMPILER MATCHES "c\\+\\+"))
+ elseif (CMAKE_CXX_COMPILER MATCHES "g\\+\\+")
set(GXX_WARNING_FLAGS
-pedantic
-Wall