summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2023-12-06 01:44:53 +0000
committerGitHub <noreply@github.com>2023-12-06 01:44:53 +0000
commitd270aa7b30f6cb0973467806b6b318c9fc39de47 (patch)
treed2a20d9658c3c78ca91e29e9a8343847f55c8516 /test/CMakeLists.txt
parenta0bd969581a5cf3a3f88c74ba31e4764d7b24fd2 (diff)
parentecbfaa9c2e6733d516351d0a815b4cd822bfed39 (diff)
downloadfork-ledger-d270aa7b30f6cb0973467806b6b318c9fc39de47.tar.gz
fork-ledger-d270aa7b30f6cb0973467806b6b318c9fc39de47.tar.bz2
fork-ledger-d270aa7b30f6cb0973467806b6b318c9fc39de47.zip
Merge pull request #2311 from afh/modernize-test-scripts
tests: Modernize test scripts
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 30ee993f..25d91a9e 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -23,7 +23,7 @@ macro(add_ledger_harness_tests _class)
if ((TestFile_IsPythonTest EQUAL -1) OR HAVE_BOOST_PYTHON)
add_test(NAME ${_class}Test_${TestFile_Name}
COMMAND ${Python_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/RegressTests.py
- $<TARGET_FILE:ledger> ${PROJECT_SOURCE_DIR}
+ --ledger $<TARGET_FILE:ledger> --sourcepath ${PROJECT_SOURCE_DIR}
${TestFile} ${TEST_PYTHON_FLAGS})
set_tests_properties(${_class}Test_${TestFile_Name}
PROPERTIES ENVIRONMENT "TZ=${Ledger_TEST_TIMEZONE}")