summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2012-05-19 19:32:40 -0500
committerJohn Wiegley <johnw@newartisans.com>2012-05-20 04:48:05 -0500
commit4681e58d7f3cda2a2ac6d05b6ec1a106f568e029 (patch)
tree488d6531d688c68713baa5c1d70fb37be198b861 /test/unit/CMakeLists.txt
parent303976e563608d8a1f4eb09ac5c9402ae5ce74fd (diff)
downloadfork-ledger-4681e58d7f3cda2a2ac6d05b6ec1a106f568e029.tar.gz
fork-ledger-4681e58d7f3cda2a2ac6d05b6ec1a106f568e029.tar.bz2
fork-ledger-4681e58d7f3cda2a2ac6d05b6ec1a106f568e029.zip
Converted the Ledger build system to use CMake
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
new file mode 100644
index 00000000..5ecd5a87
--- /dev/null
+++ b/test/unit/CMakeLists.txt
@@ -0,0 +1,17 @@
+macro(add_ledger_test _name)
+ add_ledger_library_dependencies(${_name})
+ add_test(Ledger${_name} ${PROJECT_BINARY_DIR}/${_name})
+endmacro(add_ledger_test _name)
+
+include_directories(${PROJECT_SOURCE_DIR}/src)
+
+if(BUILD_LIBRARY)
+ add_executable(UtilTests t_times.cc)
+ add_ledger_test(UtilTests)
+
+ add_executable(MathTests t_amount.cc t_commodity.cc t_balance.cc t_expr.cc)
+ add_ledger_test(MathTests)
+
+ set_target_properties(check PROPERTIES DEPENDS LedgerUtilTests)
+ set_target_properties(check PROPERTIES DEPENDS LedgerMathTests)
+endif()