summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
new file mode 100644
index 00000000..5ecd5a87
--- /dev/null
+++ b/test/unit/CMakeLists.txt
@@ -0,0 +1,17 @@
+macro(add_ledger_test _name)
+ add_ledger_library_dependencies(${_name})
+ add_test(Ledger${_name} ${PROJECT_BINARY_DIR}/${_name})
+endmacro(add_ledger_test _name)
+
+include_directories(${PROJECT_SOURCE_DIR}/src)
+
+if(BUILD_LIBRARY)
+ add_executable(UtilTests t_times.cc)
+ add_ledger_test(UtilTests)
+
+ add_executable(MathTests t_amount.cc t_commodity.cc t_balance.cc t_expr.cc)
+ add_ledger_test(MathTests)
+
+ set_target_properties(check PROPERTIES DEPENDS LedgerUtilTests)
+ set_target_properties(check PROPERTIES DEPENDS LedgerMathTests)
+endif()