summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8eb15b8b..36b35c89 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -178,8 +178,12 @@ ledger_so_SOURCES = \
src/py_amount.cc
ledger_so_DEPENDENCIES = libledger.la gdtoa/libgdtoa.la libpyledger.la
-PYLIBS = pyledger ledger gdtoa gmp boost_date_time \
- boost_signals boost_filesystem boost_regex boost_python
+PYLIBS = pyledger ledger gdtoa gmp
+if USE_BOOST_SD
+PYLIBS += boost_date_time-sd boost_filesystem-sd boost_regex-sd boost_python-sd
+else
+PYLIBS += boost_date_time boost_filesystem boost_regex boost_python
+endif
if HAVE_EXPAT
PYLIBS += expat
@@ -234,7 +238,7 @@ PyUnitTests: $(srcdir)/tests/python/PyUnitTests.py
| sed "s/%builddir%/$(ESC_builddir)/g" > $@
chmod 755 $@
-fullcheck: UnitTests
+fullcheck: check
MallocGuardEdges=1 \
MallocScribble=1 \
MallocPreScribble=1 \