summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2007-05-08 03:43:51 +0000
committerJohn Wiegley <johnw@newartisans.com>2008-04-13 03:38:41 -0400
commit02c88132cfbd69a65f5f27c0c7efbf459a375283 (patch)
tree7dadfae7fce709a7faf4ca6fd85511fb9a3824ab /Makefile.am
parent0c10d1c3fdf4fa17e9880d318ee37c4b45d0daf2 (diff)
downloadfork-ledger-02c88132cfbd69a65f5f27c0c7efbf459a375283.tar.gz
fork-ledger-02c88132cfbd69a65f5f27c0c7efbf459a375283.tar.bz2
fork-ledger-02c88132cfbd69a65f5f27c0c7efbf459a375283.zip
Added --enable-boost-sd for linking about the static/debug variant of Boost.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8eb15b8b..36b35c89 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -178,8 +178,12 @@ ledger_so_SOURCES = \
src/py_amount.cc
ledger_so_DEPENDENCIES = libledger.la gdtoa/libgdtoa.la libpyledger.la
-PYLIBS = pyledger ledger gdtoa gmp boost_date_time \
- boost_signals boost_filesystem boost_regex boost_python
+PYLIBS = pyledger ledger gdtoa gmp
+if USE_BOOST_SD
+PYLIBS += boost_date_time-sd boost_filesystem-sd boost_regex-sd boost_python-sd
+else
+PYLIBS += boost_date_time boost_filesystem boost_regex boost_python
+endif
if HAVE_EXPAT
PYLIBS += expat
@@ -234,7 +238,7 @@ PyUnitTests: $(srcdir)/tests/python/PyUnitTests.py
| sed "s/%builddir%/$(ESC_builddir)/g" > $@
chmod 755 $@
-fullcheck: UnitTests
+fullcheck: check
MallocGuardEdges=1 \
MallocScribble=1 \
MallocPreScribble=1 \