summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlon Zakai <azakai@google.com>2024-05-15 16:26:58 -0700
committerGitHub <noreply@github.com>2024-05-15 16:26:58 -0700
commit268feb9d77b66d60649682d62a93baa3daadd143 (patch)
treeecbb309453b0c398b4cee7202a5f6a05336787bb /CMakeLists.txt
parent2b60f8a212c0e744d0dbf3346498b08c9a27a39e (diff)
downloadbinaryen-268feb9d77b66d60649682d62a93baa3daadd143.tar.gz
binaryen-268feb9d77b66d60649682d62a93baa3daadd143.tar.bz2
binaryen-268feb9d77b66d60649682d62a93baa3daadd143.zip
[NFC] Disable a warning that happens on system headers on CI (#6597)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a8af137c..41b865612 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,6 +289,10 @@ else()
if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
# Google style requires this, so make sure we compile cleanly with it.
add_compile_flag("-Wctad-maybe-unsupported")
+ # Disable a warning that started to happen on system headers (so we can't
+ # fix it in our codebase) on github CI:
+ # https://github.com/WebAssembly/binaryen/pull/6597
+ add_compile_flag("-Wno-deprecated-declarations")
endif()
if(WIN32)