summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a8af137c..41b865612 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,6 +289,10 @@ else()
if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
# Google style requires this, so make sure we compile cleanly with it.
add_compile_flag("-Wctad-maybe-unsupported")
+ # Disable a warning that started to happen on system headers (so we can't
+ # fix it in our codebase) on github CI:
+ # https://github.com/WebAssembly/binaryen/pull/6597
+ add_compile_flag("-Wno-deprecated-declarations")
endif()
if(WIN32)