summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2008-08-05 13:17:04 -0400
committerJohn Wiegley <johnw@newartisans.com>2008-08-05 18:05:49 -0400
commitf6f4a46cf5b14f9a2170cd6475958efbf320caec (patch)
tree05bc1defcdebc201de3dd10477483d906a842821 /python/setup.py
parentb7970b29855563e4c67f85af8b31233eda80c22a (diff)
downloadledger-f6f4a46cf5b14f9a2170cd6475958efbf320caec.tar.gz
ledger-f6f4a46cf5b14f9a2170cd6475958efbf320caec.tar.bz2
ledger-f6f4a46cf5b14f9a2170cd6475958efbf320caec.zip
Moved around most of the files so that source code is in src/, documentation
is in doc/, etc.
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
new file mode 100755
index 00000000..4413a88d
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,19 @@
+#!/usr/bin/env python
+
+from distutils.core import setup, Extension
+
+import os
+
+defines = [('PYTHON_MODULE', 1)]
+libs = os.environ["PYLIBS"].split()
+
+setup(name = "Ledger",
+ version = "2.7",
+ description = "Ledger Accounting Library",
+ author = "John Wiegley",
+ author_email = "johnw@newartisans.com",
+ url = "http://www.newartisans.com/software/ledger.html",
+ ext_modules = [
+ Extension("ledger",
+ [os.path.join(os.environ['SRCDIR'], "pyledger.cc")],
+ define_macros = defines, libraries = libs)])