summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdmund Wu <22758444+eadwu@users.noreply.github.com>2020-10-23 15:21:11 -0400
committerGitHub <noreply@github.com>2020-10-23 12:21:11 -0700
commit1eb5e2c5b7409a64c6e610fb74df3e5b61394cfc (patch)
treec8a0f3477c9d3c2754fdec1914da7aee9b2f4dec /CMakeLists.txt
parent807580497711003aaab04c5e383f5118b3133104 (diff)
downloadwabt-1eb5e2c5b7409a64c6e610fb74df3e5b61394cfc.tar.gz
wabt-1eb5e2c5b7409a64c6e610fb74df3e5b61394cfc.tar.bz2
wabt-1eb5e2c5b7409a64c6e610fb74df3e5b61394cfc.zip
wasm2c: build library wasm-rt-impl (#1408)
Also include header files needed for compilation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5cd5650..d8ccdfb8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@
cmake_minimum_required(VERSION 3.0.0)
project(WABT VERSION 1.0.13)
+include(GNUInstallDirs)
if (POLICY CMP0077)
cmake_policy(SET CMP0077 NEW)
@@ -345,6 +346,12 @@ set(WABT_LIBRARY_SRC
add_library(wabt STATIC ${WABT_LIBRARY_SRC})
+IF (NOT WIN32)
+ add_library(wasm-rt-impl STATIC wasm2c/wasm-rt-impl.c wasm2c/wasm-rt-impl.h)
+ install(TARGETS wasm-rt-impl DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ install(FILES wasm2c/wasm-rt.h wasm2c/wasm-rt-impl.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+endif ()
+
if (BUILD_FUZZ_TOOLS)
set(FUZZ_FLAGS "-fsanitize=fuzzer,address")
add_library(wabt-fuzz STATIC ${WABT_LIBRARY_SRC})