summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorShravan Narayan <shravanrn@gmail.com>2024-01-30 19:37:52 -0600
committerShravan Narayan <shravanrn@gmail.com>2024-01-30 20:23:18 -0600
commit80b4f087aa65a7f23d3489f80eaa298a1cdb3913 (patch)
tree56d3c49897d6245dc670cf0591965db147b31e9b /CMakeLists.txt
parentcb76e5cd81312e4dba52a06cfc6bc35f795e05bb (diff)
downloadwabt-80b4f087aa65a7f23d3489f80eaa298a1cdb3913.tar.gz
wabt-80b4f087aa65a7f23d3489f80eaa298a1cdb3913.tar.bz2
wabt-80b4f087aa65a7f23d3489f80eaa298a1cdb3913.zip
wasm2c: atomic and shared mem operations using c11
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b90b50b..a7d3f4b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -423,9 +423,10 @@ if (WABT_INSTALL_RULES)
endif ()
if (HAVE_SETJMP_H)
- set(WASM_RT_FILES "wasm2c/wasm-rt-impl.h" "wasm2c/wasm-rt-impl.c" "wasm2c/wasm-rt-exceptions-impl.c")
+ set(WASM_RT_FILES "wasm2c/wasm-rt-impl.h" "wasm2c/wasm-rt-impl.c" "wasm2c/wasm-rt-exceptions-impl.c" "wasm2c/wasm-rt-mem-impl.c")
add_library(wasm-rt-impl STATIC ${WASM_RT_FILES})
+ target_link_libraries(wasm-rt-impl ${CMAKE_THREAD_LIBS_INIT})
add_library(wabt::wasm-rt-impl ALIAS wasm-rt-impl)
if (WABT_BIG_ENDIAN)
target_compile_definitions(wasm-rt-impl PUBLIC WABT_BIG_ENDIAN=1)