summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Clegg <sbc@chromium.org>2020-01-31 13:35:27 -0800
committerGitHub <noreply@github.com>2020-01-31 13:35:27 -0800
commitd18058fe482a75ec8fefbef56d27cf5c8e36afd8 (patch)
tree1194a4e8e239013713d38123275c636e74d3646a /CMakeLists.txt
parentea255e38b9bcc072ae7f1fc8062e208ed88c121f (diff)
downloadwabt-d18058fe482a75ec8fefbef56d27cf5c8e36afd8.tar.gz
wabt-d18058fe482a75ec8fefbef56d27cf5c8e36afd8.tar.bz2
wabt-d18058fe482a75ec8fefbef56d27cf5c8e36afd8.zip
Remove support for python2 (#1321)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efb60181..dbe7597d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -515,14 +515,9 @@ if (NOT EMSCRIPTEN)
set(USES_TERMINAL USES_TERMINAL)
endif ()
+ # Python 3.5 is the version shipped in Ubuntu Xenial
+ find_package(PythonInterp 3.5 REQUIRED)
# test running
- # TODO(sbc): Requrie python3 for running tests.
- # For now we don't set a version here due to and issue with github actions
- # where python 2.7 is in the PATH as "python.exe" but a mingw version is
- # installed as "python2.7.exe" and cmake will alwasy choose the later (which
- # we don't want) if we specify 2.7 explictly here.
- # See: https://github.com/actions/setup-python/issues/40
- find_package(PythonInterp REQUIRED)
set(RUN_TESTS_PY ${WABT_SOURCE_DIR}/test/run-tests.py)
add_custom_target(run-tests