summaryrefslogtreecommitdiff
path: root/libs/raylib/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Sas <sas.luca.alex@gmail.com>2020-10-01 19:17:58 +0100
committerLuca Sas <sas.luca.alex@gmail.com>2020-10-01 19:17:58 +0100
commit45ee5878397822c41b9109d0e3bc2d635c8c8634 (patch)
treee94f7a4c3d7c94760ff5b96886a2632f0d3d5f6b /libs/raylib/src/CMakeLists.txt
parent224c1c2087195c48d4a116ba9db0faa209e50332 (diff)
downloadgamejam-slgj-2024-45ee5878397822c41b9109d0e3bc2d635c8c8634.tar.gz
gamejam-slgj-2024-45ee5878397822c41b9109d0e3bc2d635c8c8634.tar.bz2
gamejam-slgj-2024-45ee5878397822c41b9109d0e3bc2d635c8c8634.zip
Updated to raylib 3.0
Diffstat (limited to 'libs/raylib/src/CMakeLists.txt')
-rw-r--r--libs/raylib/src/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/libs/raylib/src/CMakeLists.txt b/libs/raylib/src/CMakeLists.txt
index c1d4a41..2cee1b6 100644
--- a/libs/raylib/src/CMakeLists.txt
+++ b/libs/raylib/src/CMakeLists.txt
@@ -3,8 +3,8 @@ project(raylib C)
include(GNUInstallDirs)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/../cmake")
-set(PROJECT_VERSION 2.5.0)
-set(API_VERSION 251)
+set(PROJECT_VERSION 3.0.0)
+set(API_VERSION 301)
include("CMakeOptions.txt")
include(BuildType)
@@ -263,6 +263,11 @@ file(COPY "raymath.h" DESTINATION ".")
file(COPY "raudio.h" DESTINATION ".")
# Print the flags for the user
+if (DEFINED CMAKE_BUILD_TYPE)
+ message(STATUS "Generated build type: ${CMAKE_BUILD_TYPE}")
+else()
+ message(STATUS "Generated config types: ${CMAKE_CONFIGURATION_TYPES}")
+endif()
message(STATUS "Compiling with the flags:")
message(STATUS " PLATFORM=" ${PLATFORM_CPP})
message(STATUS " GRAPHICS=" ${GRAPHICS})